{"id":"EM-20261106-ENHJ","url":"https://cyber.eventmonitor.net/incident/EM-20261106-ENHJ/critical-amazon-aurora-postgresql-vulnerability-cve-2026-119923/","type":"cve","title":"Critical Amazon Aurora PostgreSQL Vulnerability (CVE-2026-119923)","subtitle":"CVE-2026-119923","subject":"CVE-2026-119923","status":"Developing","severity":"critical","affected":[],"headline":null,"born":"2026-11-06T21:31:26.000Z","firstSignal":"2026-11-06T19:17:39.360Z","lastSignal":"2026-11-06T21:31:26.000Z","updated":"2026-11-08T01:53:30.937Z","revision":1,"life":[{"status":"Born","at":"2026-11-06T21:31:26.000Z","why":"second independent source: C29 CIRCL Vulnerability-Lookup"},{"status":"Developing","at":"2026-11-06T21:31:26.000Z","why":"signals keep joining"}],"changeLog":[{"at":"2026-11-06T19:17:39.360Z","what":"First signal: C6 NVD CVE API 2.0"},{"at":"2026-11-06T21:31:26.000Z","what":"Born: second source, C29 CIRCL Vulnerability-Lookup. Page EM-20261106-ENHJ created."}],"stages":[{"name":"Disclosed","at":"2026-11-06T19:17:39.360Z","detail":"C6 NVD published"},{"name":"Scored","at":"2026-11-06T19:17:39.360Z","detail":"CVSS 9.3 · EPSS 0.6%"},{"name":"Exploited","at":null,"detail":"No exploitation reported"},{"name":"Advisories","at":null,"detail":"None yet"},{"name":"Vendor Response","at":null,"detail":"None in sources yet"},{"name":"Resolved","at":null,"detail":"After 14 quiet days"}],"signals":[{"at":"2026-11-06T19:17:39.360Z","source":"C6","sourceName":"NVD CVE API 2.0","role":"Database","severity":4,"title":"CVE-2026-119923 (CVSS 9.3)","text":"A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote attackers to execute arbitrary OS commands as the database process user via a specially crafted malformed TDS prelogin packet to the TDS port. This record consolidates a related NULL-pointer-dereference finding in the same prelogin parser.\n\n\n\nTo remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. As a…","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-119923"},{"at":"2026-11-06T21:31:26.000Z","source":"C29","sourceName":"CIRCL Vulnerability-Lookup","role":"Database","severity":2,"title":"GHSA-g64g-7679-7c73 / CVE-2026-119923","text":"A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote attackers to execute arbitrary OS commands as the database process user via a…","url":"https://vulnerability.circl.lu/vuln/GHSA-g64g-7679-7c73"}],"crowd":[],"reference":{"nvd":{"published":"2026-11-06T19:17:39.360","score":9.3,"severity":"CRITICAL","desc":"A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote attackers to execute arbitrary OS commands as the database process user via a…","product":"","seen":1794098667825},"kev":null,"epss":{"epss":0.00621,"pct":0.5004,"at":1794102810937},"p0":false},"mergedInto":null,"publisher":"Event Monitor Cyber"}